解决WDCP3.1安装make: *** [ext/fileinfo/libmagic/apprentice.lo] 错误

2017年1月13日14:50:46
评论
2,422 526字阅读1分45秒

阅读提示:可以先阅读WDCP v3默认版本升级PHP7.0正式版编译安装这篇文章

WDCP v3默认版本升级PHP7.0正式版编译安装

自从WDCP发布V3版本之后,好像用的人又多了起来,经常看到有些网友在Linux VPS中安装WDCP面板,这不在V3版本之后升级内置的组件软件支持,比如当前自定义安装可以PHP7.1,MySQL5.6等版本,相对来说可视化面板管理站点对于新手用户来说还是较为方便的。

刚才一位网友在安装V3.1版本的时候出现问题,提示"make: *** [ext/fileinfo/libmagic/apprentice.lo] Error"错误。

解决WDCP3.1安装make: *** [ext/fileinfo/libmagic/apprentice.lo] 错误

根据错误提示,应该是这位朋友VPS低于1GB内存配置的,低于这个配置应该是提示这个错误内存不足编译安装。如果类似之前的快速RMP安装版本是可以的,那就要解决问题了。

/lib/php.sh

在我们当前WDCP编译包目录下,找到这个文件,然后添加"--disable-fileinfo \"。

解决WDCP3.1安装make: *** [ext/fileinfo/libmagic/apprentice.lo] 错误

在"./configure --prefix=$IN_DIR/$PHP_DIR \"后面添加,添加保存。

最后,我们再重新运行安装WDCP脚本

sh lanmp.sh

重新安装编译,如果自定义安装的后面 加上cus选择自定义包。

weinxin
微信公众号
关注大鸟博客公众号
大鸟
匿名

发表评论

匿名网友

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: