解决Debian环境无法update更新源问题及更换阿里云镜像

2016年12月27日 评论 1,167 893字阅读2分58秒

无论我们是准备在VPS服务器中安装WEB环境,还是编译其他的软件功能,拿到VPS登录SSH之后我们肯定想到的先update环境这样可以确保服务器中的源是最新且还可以确保补丁最新。今天有在一台Debian环境中apt-get update更新源的时候有看到错误信息,而后肯定无法通过直接apt-get安装需要的软件(我需要安装SQLITE)。

解决Debian环境无法update更新源问题及更换阿里云镜像

从上图中可以看到源不通或者失效,所以才会有"E: Some index files failed to download, they have been ignored, or old ones used instead."的错误提示问题,那我们如何解决问题呢?

如果我们也是Debian环境,那就修改阿里云源,这样可以解决这个问题,当然还有其他源比如163等,我们用户不管了,谁好用老左就用哪个。

第一、替换文件

/etc/apt/sources.list

第二、替换源内容

deb http://mirrors.aliyun.com/debian wheezy main contrib non-free
deb-src http://mirrors.aliyun.com/debian wheezy main contrib non-free
deb http://mirrors.aliyun.com/debian wheezy-updates main contrib non-free
deb-src http://mirrors.aliyun.com/debian wheezy-updates main contrib non-free
deb http://mirrors.aliyun.com/debian-security wheezy/updates main contrib non-free
deb-src http://mirrors.aliyun.com/debian-security wheezy/updates main contrib non-free

我们将sources.list的内容全部替换成上面的阿里云源,然后再重新apt-get update -y之后可以完成更新。

解决Debian环境无法update更新源问题及更换阿里云镜像

我们可以看到没有错误提示,那就说明解决问题了。

继续阅读
  • 我的微信
  • 分享宝塔面板建站技术交流等!
  • weinxin
  • 微信公众号
  • 关注本博公众号
  • weinxin
  • 文本由 发表于 2016年12月27日
  • 除非特殊声明,本站文章均为原创,转载请务必保留本文链接
匿名

发表评论

匿名网友

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: