宝塔面板出现数据库错误:Warning in ./libraries/plugin_interface.lib….的解决方法!

2018年12月5日23:08:02宝塔面板228,164字数 653阅读模式

不知道有没有同学碰到,数据库错误:Warning in ./libraries/plugin_interface.lib....,大鸟今天到是碰到了。找了原因发现是phpmyadmin版本不兼容当前使用的php版本导致的。

大鸟的服务器环境是,宝塔面板6.7,  php7.2 、mysql 5.5.57,nginx-1.14.1。这个问题解决起来也比较容易,升级phpmyadmin的版本即可。宝塔面板出现数据库错误:Warning in ./libraries/plugin_interface.lib….的解决方法!

phpmyadmin与PHP匹配说明:如果只有PHP5.2,请安装 phpmyadmin4.1。如果只有PHP5.5及以下版本,请安装phpmyadmin4.4。如果只有PHP7.x,请安装phpmyadmin4.7/4.8版本!大鸟这里用的是phpmyadmin4.4的版本,所以出现了这个错误。

用宝塔面板安装phpmyadmin 还是很方便的。

第一,卸载旧版本

到后台软件管理中,卸载phpmyadmin4.4!宝塔面板出现数据库错误:Warning in ./libraries/plugin_interface.lib….的解决方法!

第二、安装新版本

宝塔面板出现数据库错误:Warning in ./libraries/plugin_interface.lib….的解决方法!

额,没啥好说的,这样之后就可以了。

第三、总结

重新安装下phpmyadmin版本,php7.2的需要phpmyadmin4.7/4.8版本的即可,或者我们换个低版本的php也可以。

解决方法总结:

在软件管理 - phpmyadmin - 设置 - PHP版本

然后选择其它PHP版本即可。

phpmyadmin与PHP匹配说明:

如果只有PHP5.2,请安装 phpmyadmin4.1

如果只有PHP5.5及以下版本,请安装phpmyadmin4.4

如果只有PHP7.x,请安装phpmyadmin4.7/4.8版本!

weinxin
微信公众号
关注大鸟博客公众号
大鸟
宝塔面板docker安装umami 宝塔面板

宝塔面板docker安装umami

umami是个小巧好用的第三方统计站点程序,之前也介绍过umami的其他安装方法,这篇文章我们还是用宝塔面板来安装,不过这次的安装是用docker来安装该程序。宝塔服务器面板,一键全能部署及管理,送你...
aapanel安装Flarum正式版 宝塔面板

aapanel安装Flarum正式版

目前Flarum正式版的最新版本是1.2,这篇文章就利用宝塔面板的英文版本aapanel来安装这个论坛程序。至于如何利用宝塔面板来安装前面已经详细介绍过。可以看教程,宝塔面板安装Flarum – 一款...
评论  2  访客  2
    • liu
      liu 1

      牛逼o( ̄▽ ̄)d

      • liu
        liu 1

        我直接在phpmyadmin4.7——设置 里面改了个php版本 就好了
        牛逼 感谢博主

      匿名

      发表评论

      匿名网友

      :?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

      确定