CentOS系统快速通过yum安装nodejs和npm工具方法

2017年2月25日 评论 518 549字阅读1分49秒

原本今天大鸟是在琢磨一个前一段时间在网上找到的一键安装Ghost博客脚本的,无奈源安装包作者删除,导致文件获取不到,然后尝试修复脚本还有部分没有成功。所以在这篇文章中就没有办法发布,以后如果修复完成再分享。所以说啊,有些时候看到好东西得及时放到本地来,要不等用的时候找不到。

在修复过程中因为需要用到nodejs和npm,如果采用直接的yum安装方法版本太低好像不兼容最新的Ghost程序,但是直接wget官方源再编译好像也比较大,这里直接采用也是官方的新的yum安装方式。这里先记录下来,别到时候又忘记了。

第一、选择合适的版本安装

# 4.x版本
curl --silent --location https://rpm.nodesource.com/setup_4.x | bash -

# 5.x版本
curl --silent --location https://rpm.nodesource.com/setup_5.x | bash -

因为默认的yum安装是0.1.x版本 ,太低了,这里我们直接可以选择比较新的4.X和5.X版本。

CentOS系统快速通过yum安装nodejs和npm工具方法

第二、快速安装

yum install -y nodejs

这个时候我们再执行yum安装就是指定的版本。

第三、检查nodejs和npm版本

CentOS系统快速通过yum安装nodejs和npm工具方法

这里我们可以看到node v5.12.0,npm版本是v3.8.6。

  • 我的微信
  • 分享宝塔面板建站技术交流等!
  • weinxin
  • 微信公众号
  • 关注本博公众号
  • weinxin
匿名

发表评论

匿名网友

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: